Degraded Document performance working in EZLynx platform

Incident Report for EZLynx

Resolved

The root cause of the disruption has been identified, and a fix has been successfully deployed. For the best experience, please close your browser and reopen EZLynx.
Posted Jun 26, 2026 - 09:55 CDT

Investigating

We are experiencing degraded performance within Document workflows. The underlying cause of the disruption has been identified and they are actively working to fully restore availability.
Posted Jun 26, 2026 - 09:23 CDT
This incident affected: Management System.